baserCMS 3.0.5.1から4.0.1にバージョンアップデート

hiroki > baserCMS 3.0.5.1から4.0.1にバージョンアップデート @ 2017/4/17 9:48
バージョンのアップデートを手順通りにFTPから「lib」フォルダの書き換えを行いましたが、その後、サーバーの読み込みエラーとなりました。
復帰の仕方が分からず問い合わせました。ホームページ中身のバックアップは取っています。
App.php ファイルの221行目でエラーが発生しております。
----------------------------------------------
該当ファイルの221行目の記述
if (!empty(static::$legacy[$type])) {
----------------------------------------------
よろしくお願いします。
katokaisya > Re: baserCMS 3.0.5.1から4.0.1にバージョンアップデート @ 2017/4/17 10:26
hirokiさん こんにちは。
引用:
バージョンのアップデートを手順通りに

とのことですが、
どのような手順で行われましたでしょうか?

4.0.0→4.0.1の手順で行っていませんでしょうか?
3系から4系にバージョンアップする際には、「lib」フォルダの書き換えだけではうまく行きません。
baserCMS3系から4系への移行方法
このあたりを参考にされると良いかと思います。

また、エラーメッセージ、どこの画面で止まっているかなどが分かると、回答がつきやすいかもしれません。
hiroki > Re: baserCMS 3.0.5.1から4.0.1にバージョンアップデート @ 2017/4/17 11:34
katokaisyaさん ありがとうございます。

4.0の手順で行い、前回のlibフォルダに上書きしました。
その後、basercmsのログイン画面でエラーとなりました。

・エラー内容:Parse error: syntax error, unexpected T_STATIC, expecting T_STRING or T_VARIABLE or '$' in /home/users/1/lolipop.jp-○○○/web/www.○○○.com/lib/Cake/Core/App.php on line 221

hiroki > Re: baserCMS 3.0.5.1から4.0.1にバージョンアップデート @ 2017/4/26 10:50
自己解決しました。
再インストールしてFTPから前回使用のテーマフォルダからデータを吸い上げて、
現在使用のテーマに反映させました。
少し変えたい部分もありましたのでバージョンアップができて良かったです。
お騒がせ致しました。
ログイン
ユーザー名:
パスワード:


  新規登録 / パスワード紛失

検索

facebook
フォーラムで悩みが解決した場合など、よかったら「いいね!」をポチっとクリックしてください!質問の回答者や開発者の励みになります

フォーラムガイド


関連リンク

オンライン状況
16 人のユーザが現在オンラインです。 (13 人のユーザが フォーラム を参照しています。)

登録ユーザ: 0
ゲスト: 16