Gallery Site(4系)の背景について

はじめまして。
昨日からホームページを作成しようと登録しました。

今回、作成したいのがギャラリーのあるものだったので「Gallery Site(4系)」を使用させていただきたいと思い、ダウンロードしました。

サンプルの背景は白だったのですが、ダウンロード後反映した自身のページを見ると背景が真っ黒で当惑しています。

cssを触って修正するものなのか、そもそもなにかのバグで開発者の方に修正をお願いしないといけないのか分からずそのまま置いてしまっています。

私はhtmlのタグが多少わかるくらいの素人です。
どなたかお教えいただけますと幸いです。

【環境情報】
・baserCMSのバージョン:4.4.4
・レンタルサーバー名:ロリポップ
・使用テーマ: Gallery Site(4系)
・PHPスキル(自己評価): 全くわからない

テスト環境にGallery Site(4系)のテンプレートを適用してみましたが、特に背景が黒になるようなことはありませんでしたので、バクと言うことではないと思います。

CSSも上記のようにbody要素の背景属性に#fffが指定されていますので、背景は白のはずです。

一度、ブラウザのキャッシュおよびサーバーキャッシュの削除をしてみてはいかがでしょうか。

GUSSAN様

ご回答いただきありがとうございます。

ブラウザ(Chromeをつかっています)のキャッシュクリアをしたり、シークレットモードでひらいてみましたが、だめでした。

私の方もCSSはGUSSAN様と同じく#fffと記載されていましたので、白で間違いないかと思います。

サーバーのキャッシュはどこでするのでしょうか?
baserCMSの管理画面右上にある「キャッシュのクリア」というボタンは何度かクリックしました。

macなので、Safariでも開いてみたのですが、
同じで、文字などは表示されませんでした>_<

トップページの文章に、修正は/Elements/top_info.phpなどが書いてあるのですが、
私がダウンロードしたElementsフォルダ内には[contents_menu.php]しかありませんでした。
これも何か関係したりしているのでしょうか?

わからないので、的はずれなことを言っているかもしれません。
すみません。
ご連絡お待ちしております。

度々すみません。
他のテンプレートに変更してみたところ、他のテンプレートでも背景が真っ黒でした。
このテンプレートの中身がが問題ではなかったのかなと思いますが、それならどこの設定なんだろうとまた当惑しています…

ChromeとSafariのブラウザ設定でしょうか。

もし、何かココを触ってみては?というところがあればお教えいただけますと幸いです。

@oyo-chan さんが添付されたTOP画面の背景色は確かに黒ですが、グローバルメニューのレイアウトも私の環境のTOP画面と違うようですので、なにか読み込まれていないCSSがあるのかもしれません。


キャッシュクリアの位置も妙ですね。。。

思うんですが、そもそもbaserCMS自体がちゃんとインストールされていないのではないでしょうか?
baserCMSは、LOLIPOPの簡単インストールでしょうか?
正しくインストールされていれば、管理画面のツールバーは、こんな感じに見えるはずですんで。。。

ご返信有難うございます。

添付した画像はsafariで開いたときの画像です。
Chromeだとこんな感じになって、背景色以外はGUSSAN様と同じ画面かと思います。

きちんとインストールがされていないということがあるんですね;;
インストールはLOLIPOPの簡単インストールを使いました。

なるほど、確かにChromeの表示とおっしゃってる方は、あまり違和感ないですね。。。
LOLIPOPの簡単インストールを使ってインストロールされたのであれば、うまくインストールできないということは考えにくいのですが、baserCMSの公式サイトからダウンロードされたものをFTPなどを使ってサーバーにご自身でアップロードし、インストール(あるいはアップデート)された場合には、FTPの転送過程で必要なファイルがアップロードされていなかったりなどして、うまくインストールされていないということがあります。

さて、必要なファイルが漏れなくアップロードされているとすると、どうしてなのか。。。
@oyo-chan さんのお話しぶりでは、style.cssのbody要素の背景の#fffも効いているとのことですし。。。

しかし、いずれにしても、ChromeとSafariのように単なるブラウザが違うということだけで、ここまでレイアウト表示が違うことはちょっと考えられないと思います。Windowsの古いIEとMac対応のモダンブラウザの比較ならあるかもしれませんが。。。
なので、今回試されているChromeとSafariいずれのブラウザでも、何らかの理由で、本来読み込むべきCSSを読み込めていないのではないのかなぁと、事の大小はあるにせよ。

ブラウザの開発ツールで調べてみて、読み込みエラーが出ていませんか?

GUSSAN様

ご連絡ありがとうございます。
昨日、私用でパソコンを開いていなかったもので、返事が遅くなってしまいました。
メッセージの方もお気遣いいただいたのに、気付けず申し訳ありません。

お教えいただいたように開発者ツールで見てみると、#fffのところに線が入っていました。
これが読み込まれていないということでしょうか…?

スクリーンショット 2021-05-31 10.15.40

もしかすると、テーマ設定内の色指定の設定が上書きしているかもしれないので、確認してみてください。