4.2.4 インストール直後にエラー発生?

久しぶりにbaserCMSを使ってみました。
最新の、4.2.4 をインストールしたのですが、直後にエラーが発生しています。

error.log を見ると、
2019-10-29 23:42:37 Error: [PDOException] SQLSTATE[HY000]: General error: 1525 Incorrect DATETIME value: ‘0000-00-00 00:00:00’
Request URL: /hc/
Stack Trace:
#0 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Baser/Model/Datasource/DboSource.php(515): PDOStatement->execute(Array)
#1 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Baser/Model/Datasource/DboSource.php(481): DboSource->_execute(‘SELECT Content...', Array) #2 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Baser/Model/Datasource/DboSource.php(728): DboSource->execute('SELECTContent…’, Array, Array)
#3 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Baser/Model/Datasource/DboSource.php(1239): DboSource->fetchAll(‘SELECT `Content…’, Array)
#4 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Baser/Model/Behavior/BcCacheBehavior.php(80): DboSource->read(Object(Content), Array)
#5 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Baser/Model/BcAppModel.php(1548): BcCacheBehavior->readCache(Object(Content), false, ‘first’, Array)
#6 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Baser/Model/Content.php(1895): BcAppModel->find(‘first’, Array)
#7 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Baser/Routing/Route/BcContentsRoute.php(84): Content->findByUrl(’’, true, false, false, false)
#8 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Baser/Routing/Router.php(612): BcContentsRoute->parse(’’)
#9 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Cake/Routing/Dispatcher.php(219): Router::parse(’’)
#10 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Baser/Event/CakeEventManager.php(243): Dispatcher->parseParams(Object(CakeEvent))
#11 /home/ymatsu/public_html/harryscoffee.jp/hc/lib/Cake/Routing/Dispatcher.php(147): CakeEventManager->dispatch(Object(CakeEvent))
#12 /home/ymatsu/public_html/harryscoffee.jp/hc/index.php(123): Dispatcher->dispatch(Object(CakeRequest), Object(CakeResponse))
#13 {main}

何がおかしいのでしょうか?SQLの引数に 0 を与えているようなのですが。

■ BaserCMSのバージョン:2.4.2
■ レンタルサーバー名:さくらインターネットVPS
■ スマートURLの利用: [ON]
■ 設置フォルダ: [サブフォルダ]
■ 利用しているデータベース: [MySQL]
■ PHPスキル(自己評価): [ C ]
■ OSの種類:ubuntu 19.10
■ PHPのバージョン:7.3
■ データベース種類・バージョン : MySQL 8.0.17

すみません。自己解決しました。
mysql の sql_mode で、以下の設定に変更しました。

mysql> set session sql_mode=‘ONLY_FULL_GROUP_BY,ERROR_FOR_DIVISION_BY_ZERO,NO_ENGINE_SUBSTITUTION’;
Query OK, 0 rows affected, 1 warning (0.00 sec)

mysql> set global sql_mode=‘ONLY_FULL_GROUP_BY,ERROR_FOR_DIVISION_BY_ZERO,NO_ENGINE_SUBSTITUTION’;
Query OK, 0 rows affected, 1 warning (0.00 sec)

参考にしたページ:

1 Like