PHPを7.2以上に上げるとエラーが出てサイトが表示されなくなる

【環境情報】
・baserCMSのバージョン:4.1.0.1
・レンタルサーバー名: Xserver
・使用テーマ:専用のカスタムテーマ
・PHPスキル(自己評価):E

あるクライアントのサイトにて、PHPのバージョンを7.0.33から7.2以上に上げると
サイトが表示されなくなってしまいます。
デバッグモード1に切り替えて再度PHPを7.2.34にしたところ、
以下のようなエラーが表示されました。(一部フォルダ名を隠しています)

BurgerEditorでのエラーとのことですが、どのようにして解消すればよいかが判りません。
原因や対応方法などご存知の方居られましたら、ご教示頂けないでしょうか。

4.1.0.1は、PHP7.2のユニットテストを行っていないようなので、PHP7.2には対応できていない可能性がありますね。

以下ページを下部にスクロールすると過去バージョンのリリースに関する情報が確認できます。

回答が遅れてしまいすみません。
仰る通りbaserCMSのバージョンが古いのが原因だったようです。
バージョンを4.5まで上げた所、正常にPHPのバージョンを7.4.13に上げられました。
ありがとうございました。