あるときから突然、テーマ管理、プラグイン管理ページがエラーで使えません

現在、BaserCMSで4つのサイトを作り利用しています。

baserCMS 3.0.2(php54)
vn-bbs.net

その内、Ver. 3.0.2で稼動させているサイトの管理画面で、
テーマ管理、プラグイン管理が、ある時期から(いつか覚えていませんが、1~2年前?)エラーを起こして見られなくなりました。

忙しかったのもあり、ずっとそのままでした。

該当ドメイン内のパーミッション設定等も確認しましたが、何故、テーマ管理、プラグイン管理だけがエラー表示されてしまうのかが分からない状態です。

本当は、BaserCMSのバージョンをUPしたいのですが、
このままの状態でバージョンUPはできないでしょうか?

ちなみに
他の3つのサイトでは、テーマ管理、プラグイン管理は表示されます。

Ver.3.0.7(php54)r-g-enet

Ver.3.0.9(php53)安田音楽教室biz

Ver.4.2.3(php56)armonicanet

以上の件について、

解決方法など、ご教授いただけますとありがたいです。
よろしくお願いいたします。

【環境情報】
・baserCMSのバージョン:3.0.2
・レンタルサーバー名:CORESERVER
・使用テーマ:bccolors(多分。。。)
・データベース:MySQL
・PHP Version:5.4.45
・PHPスキル(自己評価):C~D

テーマ管理、プラグイン管理がエラーを起こしてしまう件、
パーミッション設定以外に、どのファイルを見れば良いのか?など、
どのようなことでも良いので、何かヒントは無いでしょうか?

baserCMSのバージョンをUPしたいのですが、ずっとこれが引っかかっていて、出来ない状態です。

多分、このままバージョンUPはNGですよね?

その後、自分で検索して、
http://forum-archive.basercms.net/modules/newbb/viewtopic.php?topic_id=2720&forum=8
の記事を見つけ、
その中にあったリンクに、


があったので、
早速、書き換えて試しましたが、
全く変わらずでした。

キャッシュも全部、丁寧に削除しましたが、
テーマ管理、プラグイン管理のページだけが、
同じくエラーを起こすのに変わりなく、
他に対処の方法が見つかりません。

このまま、
baserCMSのバージョンをUPするのはNGですか?

@VolinistaReiko 最近、レンタルサーバーでは、PHPのバージョンを強制的に7系にアップデートしているところが多いのでそれが影響しているかもしれません。
対応するには、baserCMSのバージョンアップをした方がよいです。
ただし、結構な作業量が発生しますのでご注意ください。
まずは、3系の最新版にアップデートし、4系の初期バージョンにアップグレード、そして、4系の最新版にアップデートという手順を踏む必要があります。

3.0.8 → 3.0.16 → 4.0.0 → 4.3.6

また、本番サーバーで実施するのはリスクがかなり高いです。
理由は、baserCMSのバージョンとPHPのバージョンがあっていないとアップデートすらうまく動作しない可能性があるからです。

3.0.8 〜 4.0.0 あたりまでは、PHP5系で動作しますが、PHP7系でうまく動作しません。

まず、別のテスト環境でPHP5系を作って、baserCMS4.0.0 あたりまでアップデートし、その後、PHP7系の環境を作ってから、baserCMS4.3.6にアップデートする必要があります。

作業に不安がある場合、専門業者にご依頼された方がよいかもしれません。
(うちの会社でも承ってます)

返信を頂きましてありがとうございます<m(__)m>

PHPのバージョンですが、coreserverは、ドメインごとにPHPのバージョンを設定できるのですが、baserCMS3.0.2(vn-bbs.net)は、php54になっています。

プロの方に頼める余裕があれば、そうするのですが、残念ながらサーバー代、ドメイン代の支払いが精一杯なので、web関連だけではないのですが、全て自力で行っています。

とりあえず、教えていただいたように、

3.0.2から
3.0.8 → 3.0.16 → 4.0.0 → 4.3.6 へと順番にアップデートをしていった方が良いということですね?

その際に、
PHPのバージョンもUPした方が良いでしょうか?

サーバーの設定を見ると、
ドメインごとに次のいずれかのバージョンに設定できるようです。

php71 php74 php73 php72 php70 php56 php55 php54 php53

お手数かけます。
よろしくお願いいたします<m(__)m>

@VolinistaReiko まずは、PHP5.6 に設定し、バージョンアップを最後まで順番に行ってください。
最新版まで引き上げたあとに、PHP7.3に変更してください。
PHP7.4 は今月末リリースするバージョンで対応予定です。

早速のご返信ありがとうございます。

教えていただいたとおりに、近々、行ってみます。

バージョンアップの状態は、追ってご報告させていただきます<m(__)m>